School navigation

Information Technology

Mavericks and Windows 8.1 Compatibility Update

November 01, 2013

  • News Image

Every major OS upgrade inevitably brings issues of compatibility. Mavericks and Windows 8.1 are not exceptions. While the decision to upgrade is up to you, please be aware of the following compatibility issues with some of our major supported software.

Computers running Mavericks that attempt to launch XpressConnect installer package will receive an “Unsupported Operating System” error. Computers that installed SafeConnect before upgrading should still be able to connect to WiFi, but if SafeConnect was never installed on the computer there will be issues with the XpressConnect installer package. Users may encounter similar issues with Windows 8.1. While the installer package may not run, a manual installation of SafeConnect can be done. Contact our HelpDesk (ext. 7225) if you have upgraded and require assistance.

Issues have also been reported for VPN software Cisco AnyConnect, which is not yet fully compatible with Mavericks or Windows 8.1. Cisco and Apple are aware of the problem, and are currently working on a solution. Mavericks and 8.1 users attempting to connect to VPN via Cisco AnyConnect are encouraged to try doing so through an Ethernet connection whenever possible, rather than wireless.

We’ll do our best to keep you informed via our news page and our twitter feed, and we will publish solutions as soon as they are available. In the meantime, please don’t hesitate to contact us with any questions or concerns.

***11/4 Update***

We have updated our VPN client to the latest version which should be fully compatible with Mavericks. You may download the newest version from vpn.lclark.edu.